BSOD при установке Windows 10, помогите разобраться
Дата обновления: 02.10.2017 - 08:16, перейти к новому сообщению
icon14
#1
psymurph



Новичок


Группа: Пользователи
Сообщений: 3
Регистрация: 1.10.2017
Пользователь №: 2.107.630


Респектов: 0
----------


Предупреждений:


Собрал себе недавно новый комп, после сборки возникли проблемы с установкой Windows 10 (как, впрочем, и многих других ОС). Вот машина:
  • Процессор: AMD Ryzen 7 1700X
  • Мат. плата: Asus Prime B350M-A (BIOS ver. 0806)
  • Память: Kingston HyperX Fury DDR4 2666MHz 2x8GB (HX426C15FBK2/16)
  • Видеокарта: Nvidia GeForce GTX 970
  • Блок питания: Corsair RM550x
  • SSD: Samsung 850 EVO 500GB
  • HDD: Western Digital Red 2TB
  • Также дополнительно поставил PCI-E WiFi-плату TP-Link N900.
Пытался установить последнюю версию винды (1703 10.0.15063), но при установке начали вылетать синие экраны с различными ошибками:
  • IRQL_NOT_LESS_OR_EQUAL (x1)
  • DRIVER_IRQL_NOT_LESS_OR_EQUAL (x2)
  • SYSTEM_THREAD_EXCEPTION_NOT_HANDLED (x6)
  • KMODE_EXCEPTION_NOT_HANDLED (x2)
  • BAD_POOL_HEADER (x1)
  • KERNEL_SEQURITY_CHECK_FAILURE (x2)
  • CRITICAL_PROCESS_DIED (x1)
  • UNXEPECTED_KERNEL_MODE_TRAP (x1)
  • 0xC000021A (x1)
БСоДы вылетают спонтанно во время установки, иногда на старте установщика, иногда в менюшках выбора языков, дисков и пр. Читал в сети о схожих проблемах на райзене - подозревают несовместимость железа. Перепробовал кучу всего для решения и диагностики. Вот результаты в хронологическом порядке:
1. Проверил как слоты платы, так и контакты планок памяти - ни пыли, ни окисления.
2. Убрал одну планку - помогло. Винда поставилась и стабильно работала на одной планке под разными нагрузками (стресс-тесты, бенчмарки, тяжелые науч. вычисления, видео, игры и пр.). Два дня тестировал - без проблем.
3. Попробовал другие слоты. Перебрал все 12 вариантов установки двух планок памяти, но независимо от слотов две планки не работали, одна - работала.
4. Проверил списки совместимости памяти и мат. платы - память в списке есть.
5. Понизил частоту памяти до 2400, 2133, 1866 - безрезультатно
6. Проверил память - больше 8 проходов Memtest86 на каждой планке отдельно и на двух вместе, полный набор тестов на всех 16 ядрах процессора - ошибок нет.
7. Сделал минимальную сборку, отключил все диски, периферию, сетевую плату, чтобы исключить драйверы на эти устройства - все те же БСОДы.
8. Много раз на протяжении всех этих манипуляций вытаскивал CMOS-батарейку на 10 сек, 1 минуту, 10 минут - никакого эффекта.
9. Попробовал поставить Windows 7. Установка запустилась, но в конце произошел ребут, после чего слетели разделы на диски, и пришлось их восстанавливать через другую, рабочу машину.
10. Пробовал поставить Linux Mint 18.3, но при загрузке Live USB в консоль прилетело лаконичное сообщение Unknown hardware! и все намертво зависло.
11. Попробовал поставить другой комплект памяти 2x8GB G.Skill Ripjaws 4 Blue DDR4 3000MHz (F4-3000C15D-16GRBB) без всякого эффекта.
12. Тогда решил, что раз с одной планкой на 8Гб работало, то возьму 1 планку на 16Гб, и дело с концом. Взял TEAM Elite DDR4 2400MHz 16GB (TED416G2400C1601), которая есть в списка совместимости как Asus, так и TEAM. Но и тут винда не завелась и никаких новых симптомов не обнаружила
13. Тогда я взял новую мать на другом чипсете - MSI X370 Gaming Plus. Но снова ничего не изменилось.
14. Вспомнил, что есть еще Windows 8.1 и попробовал поставить еще и ее. И тут ВНЕЗАПНО винда 8.1 установилась на 1х16Гб планке, адресовала все 16Гб памяти, увидела и распределяла нагрузку по всем 16 ядрам процессора и стабильно работала. Просмотрел отчет AIDA64, но ничего подозрительноного не увидел. Прогнал стресс-тест в Аиде - без проблем. Температура процессора не поднималась выше 55 градусов при 100% нагрузке, температура чипсета - выше 33 градусов. Я уже было хотел плюнуть и оставить восьмую винду, но оказалось, что она не поддерживает софт, который мне нужен для работы, а хаки заморочисты.
15. Пробовал поставить линукс по-новее - Ubuntu 17.04 ядром версии 4.10. Но при установке вылетела ошибка ACPI Error: Needed [Integer/String/Buffer], found [Region] 0xFFFF... Поколдовав немного, загрузил ее с параметром ядра acpi=off, после чего она установилась, тоже стабильно работала, но почему-то распознала только одно ядро процессора, вместо 16-ти.
16. Возил комп в сервис несколько раз. Там местные умельцы осмотрели мое железо и сказали, что каждая деталь рабочая в отдельности, поэтому это не гарантийный случай. А проблемы совместимости они не решают. Тогда отвез системник в другой сервис, но там мне сказали, что Ryzen - это еще очень новая платформа, и под нее нет тестового оборудования, и ни десятую винду ни линукс они тоже поставить не смогли.
17. Пробовал делать возврат процессора с матерью, но жучье из магазина мне сказало, что раз наклеечки на коробках срезаны, значит товарный вид нарушен, и возврату не подлежит.

Итого, перепробовал три абсолютно разных комплекта памяти, две материнки с разными чипсетами, пять операционных систем и два сервис-центра.

Помогите разобраться. Если проблема с железом, то как Windows 8.1 стабильно работает и проходит различные тесты? А если проблема с десятой виндой, то как ее можно решить?

Сообщение отредактировал psymurph - 1.10.2017 - 19:08
User is offline
Go topGo end
 

Ответов(1 - 7)
Отправлено: 1.10.2017 - 19:20
#2
s0l0m0n



Бывалый
*

Группа: Пользователи
Сообщений: 32
Регистрация: 19.11.2007
Пользователь №: 611.794


Респектов: 8
-----X----


Предупреждений:


К материнке вышел BIOS в котором обновили AGESA которая отвечает за инициализацию ядер, проблема в новизне процессоров, потому и железный софт глючный.
User is offline
Go topGo end
icon1 Отправлено: 1.10.2017 - 19:38
#3
Henry723



профи!
[SoftoRooMTeaM] Group Icon

Группа: Модераторы
Сообщений: 5.714
Регистрация: 27.10.2005
Пользователь №: 59.366


Респектов: 2687
-----XXXXX




1. Проверь БИОС материнки на вопрос установки процессора...

2. По своему опыту - из 4 планок оперативки тест прошли только две - на всех четырех 10 винда или ставилась криво или иногда в процессе установки выпадала в синий экран (похожая картина)...

3. В инете уже мелькали новые драйвера под твой процессор - на win7/8 - попробуй их при установке win 10...

Ну и результаты сюда...

P.S. Тест планок памяти надо делать на Linux, AIDA ошибки часто пропускает ...
User is offline
Go topGo end
Отправлено: 1.10.2017 - 19:56
#4
psymurph



Новичок


Группа: Пользователи
Сообщений: 3
Регистрация: 1.10.2017
Пользователь №: 2.107.630


Респектов: 0
----------


Предупреждений:


Цитата | Quote(s0l0m0n @ 1.10.2017 - 19:20)
К материнке вышел BIOS в котором обновили AGESA которая отвечает за инициализацию ядер
*


Только что обновил БИОС до 0902 - не помогло
User is offline
Go topGo end
Отправлено: 2.10.2017 - 0:44
#5
zoog



профи!
*****

Группа: Пользователи
Сообщений: 810
Регистрация: 13.09.2007
Пользователь №: 497.976


Респектов: 39
-----X----


Предупреждений: 2


Попробуйте установить без ссд и поменять САТА кабель.
User is offline
Go topGo end
Отправлено: 2.10.2017 - 1:00
#6
psymurph



Новичок


Группа: Пользователи
Сообщений: 3
Регистрация: 1.10.2017
Пользователь №: 2.107.630


Респектов: 0
----------


Предупреждений:


Цитата | Quote(zoog @ 2.10.2017 - 0:44)
Попробуйте установить без ссд и поменять САТА кабель.
*


Отключал все диски, периферию, сетевую плату и пробовал просто запустить установщик с флешки - не помогло.

Добавлено:
Цитата | Quote(Henry723 @ 1.10.2017 - 19:38)
3. В инете уже мелькали новые драйвера под твой процессор - на win7/8 - попробуй их при установке win 10...
*


Если я правильно понял, о чем ты, то я только что попытался сделать инъекцию последних драйверов чипсета в образ десятки через DISM. Не уверен, какие конкретные драйверы нужно было выбрать (их там под два десятка), поэтому зашил все. При загрузке с флешки с этим образом снова вылетел БСОД с ошибкой CRITICAL_PROCESS_DIED.
User is offline
Go topGo end
Отправлено: 2.10.2017 - 1:54
#7
zoog



профи!
*****

Группа: Пользователи
Сообщений: 810
Регистрация: 13.09.2007
Пользователь №: 497.976


Респектов: 39
-----X----


Предупреждений: 2


Цитата | Quote
Отключал все диски, периферию, сетевую плату и пробовал просто запустить установщик с флешки - не помогло.

А на что установка велась? Если бсодит просто при загрузке лайв-системы - это уже повод менять как брак.
User is offline
Go topGo end
icon1 Отправлено: 2.10.2017 - 8:16
#8
Henry723



профи!
[SoftoRooMTeaM] Group Icon

Группа: Модераторы
Сообщений: 5.714
Регистрация: 27.10.2005
Пользователь №: 59.366


Респектов: 2687
-----XXXXX




Цитата | Quote(psymurph @ 2.10.2017 - 1:00)
Если я правильно понял, о чем ты, то я только что попытался сделать инъекцию последних драйверов чипсета в образ десятки через DISM. Не уверен, какие конкретные драйверы нужно было выбрать (их там под два десятка), поэтому зашил все. При загрузке с флешки с этим образом снова вылетел БСОД с ошибкой CRITICAL_PROCESS_DIED.
*


Проверь планки памяти тестом Linux - оставь только те , что прошли все тесты без ошибок... smile.gif
User is offline
Go topGo end

Topic Options
Сейчас: 20.10.2017 - 8:13
Мобильная версия | Lite версия