Твой софтовый форум > Тематические форумы > 1С, экономический софт и литература. > 1С Конфигурации 7.7 -8* (релизы, платформы, обсуждение)

1С Конфигурации 7.7 -8* для РБ (релизы, поиск, обсуждение)

,

1С релизы, поиск, обсуждение для Республики Беларусь, 3

Дата публикации: 06.12.2019 - 12:08
Pages: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30, 31, 32, 33, 34, 35, 36, 37, 38, 39, 40, 41, 42, 43
bedulinsv
Помогите с обновлениями 1c7 Мисофт "СТО" в 2019 г.
Lerok123
Доброго дня! Может у кого-то так было и смогли решить вопрос. база 1С7.7 Мисофт 31.05 накладные вертикальные печатались на один лист, 03.06. уже разбиваю на две части. Как исправить? что могло слететь?
user2016
Галку печатать на 1 станице поставьте
JekRau
Цитата | Quote(Lerok123 @ 3.06.2019 - 11:45)
Доброго дня! Может у кого-то так было и смогли решить вопрос. база 1С7.7 Мисофт 31.05 накладные вертикальные печатались на один лист, 03.06. уже разбиваю на две части. Как исправить? что могло слететь?
*


Закладка ТТН, 2 раздел галочка "Печать верт. накл. на один лист" установлена?
liverom
Добрый день нельзя ли выложить обновление юколы за май стандрат с отчетами? Может есть у кого? в ветке вижу только апрельское обновление?
coolnex
Добрый день, вопрос к программистам. Пытаемся создать программно из прихода авансовый отчет.Процедура выглядит пока так (нужно пока чтобы он только создался без заполнения)
Процедура СоздатьАвансовыйОтчет()
Если флАО=1 Тогда
Док1=СоздатьОбъект("Документ.АвансовыйОтчет");
Док1.Новый();
Док1.ДатаДок=ДатаДок;
Док1.УстановитьНовыйНомер();
Док1.Записать();
АвансовыйОтчет=Док1.ТекущийДокумент();
КонецПроцедуры
При создании и проведении прихода если стоит галочка, то должен автоматом создаться АО, но этого соответственно не происходит. Что не так написали или недописали? Заранее спасибо
Pasha-Buh
Цитата | Quote(coolnex @ 5.06.2019 - 11:28)
При создании и проведении прихода если стоит галочка, то должен автоматом создаться АО, но этого соответственно не происходит. Что не так написали или недописали? Заранее спасибо
*



Если при записи документа, то в модуле формы:
Процедура ПриЗаписи()
СоздатьАвансовыйОтчет();
КонецПроцедуры

Если при проведении, то в модуле документа:
Процедура ОбработкаПроведения()
СоздатьАвансовыйОтчет();
КонецПроцедуры

Ваша процедура должна размещаться (в зависимости от выбора когда должен создаваться документ) или в модуле документа или в модуле формы выше описанных процедур.
Merlin1975

Lerok123
Цитата | Quote(JekRau @ 4.06.2019 - 9:15)
Закладка ТТН, 2 раздел галочка "Печать верт. накл. на один лист" установлена?
*


Спасибо кто отозвался, был какой-то глюк на две ТТН только, все стояло в обычном режиме. перегрузили систему и все восстановилось


Добавлено:
Может есть у кого свежие обновления для 1с 7,7 Мисофт Проф плюс партионный учет товаров. Давно не было обновлений. Или где почитать как обновить из любой конфы без потери доработок? Спасибо
LackyZZ
coolnex, уберите док1.Новый(); я так понимаю процедуру делаете по кнопке?
Проверьте в отладчике чему равен флаг. думаю не единице.
Быстрый ответ:

 Включить смайлики |  Добавить подпись


Pages: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30, 31, 32, 33, 34, 35, 36, 37, 38, 39, 40, 41, 42, 43


SoftoRooM.NeT lite версия, полная версия - здесь: 1С Конфигурации 7.7 -8* для РБ (релизы, поиск, обсуждение)
SoftoRooM.NeT © 2004-2019